通达信底背离建仓

求高手帮忙设:通达信macd 顶底背离+画线公式,如图,图片来自同花顺,万分感激!

DIF:EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:EMA(DIF,9);
MACD:(DIF-DEA)*2,COLORSTICK;

DRAWICON(CROSS(DIF,DEA),DEA,1);
DRAWICON(CROSS(DEA,DIF),DEA,2);
DU:=BARSLAST(CROSS(DIF,DEA));
DD:=BARSLAST(CROSS(DEA,DIF));
TJ1:=DEA<0 AND DU=0 AND REF(DEA,REF(DU,1))<DEA AND REF(C,REF(DU,1))>C;
STICKLINE(EVERY(UPNDAY(DU,1),DU),REF(DEA,DU),REF(DEA,DU),5,-1),COLORLIGRAY;
STICKLINE(TJ1,REF(DEA,REF(DU+1,1)),DEA,1,0),COLORLIGRAY;
DRAWTEXT(TJ1,REF(DEA,REF(DU,1)),'底背离'),COLORLIGRAY;
TJ2:=DEA>0 AND DD=0 AND REF(DEA,REF(DD,1))>DEA AND REF(C,REF(DD,1))<C;
STICKLINE(EVERY(UPNDAY(DD,1),DD),REF(DEA,DD),REF(DEA,DD),5,-1),COLORLIGRAY;
STICKLINE(TJ2,REF(DEA,REF(DD+1,1)),DEA,1,0),COLORLIGRAY;
DRAWTEXT(TJ2,REF(DEA,REF(DD,1)),'顶背离'),COLORLIGRAY;

股市里的底背离是什么意思?

底背离的意思就是股指与指标或成交量不是同步的也就是说如果股指创出新低,而指标或成交量没有创出新低或指标成平行运动的成为股指的底背离。反之成为指标的底背离。在这种情况下可以成为短期的买点。

通达信Macd选股怎么表达底背离

macd背离选股是需要建立选股公式的,无法通过综合选股的选择简单的上穿,或者对比大小值来实现.
需要你自己定义条件,然后把所设定的条件编辑成条件选股公式,才可以实现选股.
还有背离可以有很多种,例如dif线,dea线最低点的低背离,还有macd绿柱子,最底点的底背离.还有背驰也就是macd绿柱面积的背离.
还有金叉背离,也就是两次金叉位置的对比.等等
还可以把这些条件组合.这是需要你自己设定条件的.
图中分别是dea线和macd柱子高低点的背离.

麻烦朋友编skdj(30 3)的底背离选股公式,30个单位内的背离,通达信用,谢谢。

LOWV:=LLV(LOW,30);
HIGHV:=HHV(HIGH,30);
RSV:=EMA((CLOSE-LOWV)/(HIGHV-LOWV)*100,3);
K:=EMA(RSV,3);
D:=MA(K,3);
MAX(K,D) <=30;
说明:你只说背离,没有要求金叉吧。上面没有金叉,如果需要金叉则把最后的语句改为:
K<=30 AND CROSS(K,D);
说实话,这个选股公式不是很好用,假如在面对弱势行情时,这个指标对慢慢盘跌的股票会显示出错误的信号,其指标背离或钝化是无法指出股价是否见底。这只是我个人观点,仅供参考,你也可慢慢验证。

求高手,编写MACD指标背离时的选股公式

DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIF,9);
MACD:=(DIF-DEA)*2;
LLV(L,2)<=LLV(L,10)
AND
DIF>REF(DIF,1);
说明:我简单测试了一下,本公式选的股可以超过A股均涨幅,是一个不错的选股器。但选出的股太多,有时上千个,有时几十个,这里我做了一个限制股数量的公式可以搭配使用。但不能在这里公布。因为一个好公式大家都用它来赚钱,是赚不到钱的,联系我后发给你。

麻烦大神写个MACD顶背离的公式

MACD顶底背离副图
DIFF:EMA(CLOSE,12) - EMA(CLOSE,26);
DEA:EMA(DIFF,9);
MACD:2*(DIFF-DEA),COLORSTICK;
A1:=BARSLAST(REF(CROSS(DIFF,DEA),1));
B1:=REF(C,A1+1)>C AND REF(DIFF,A1+1)<DIFF AND CROSS(DIFF,DEA);
A2:=BARSLAST(REF(CROSS("KDJ.K"(9,3,3),"KDJ.D"(9,3,3)),1));
B2:=REF(C,A2+1)>C AND REF("KDJ.K"(9,3,3),A2+1)<"KDJ.K"(9,3,3) AND CROSS("KDJ.K"(9,3,3),"KDJ.D"(9,3,3));
A3:=BARSLAST(REF(CROSS("RSI.RSI1"(6,12,24),"RSI.RSI2"(6,12,24)),1));
B3:=REF(C,A3+1)>C AND REF("RSI.RSI1"(6,12,24),A3+1)<"RSI.RSI1"(6,12,24) AND CROSS("RSI.RSI1"(6,12,24),"RSI.RSI2"(6,12,24));
C1:=BARSLAST(REF(CROSS(DEA,DIFF),1));
D1:=REF(C,C1+1)<C AND REF(DIFF,C1+1)>DIFF AND CROSS(DEA,DIFF);
C2:=BARSLAST(REF(CROSS("KDJ.D"(9,3,3),"KDJ.K"(9,3,3)),1));
D2:=REF(C,C2+1)<C AND REF("KDJ.K"(9,3,3),C2+1)>"KDJ.K"(9,3,3) AND CROSS("KDJ.D"(9,3,3),"KDJ.K"(9,3,3));
C3:=BARSLAST(REF(CROSS("RSI.RSI2"(6,12,24),"RSI.RSI1"(6,12,24)),1));
D3:=REF(C,C3+1)<C AND REF("RSI.RSI1"(6,12,24),C3+1)>"RSI.RSI1"(6,12,24) AND CROSS("RSI.RSI2"(6,12,24),"RSI.RSI1"(6,12,24));
MACD底背:IF(B1>0,-0.1,0),COLORRED,POINTDOT;
KDJ底背:IF(B2>0,-0.1,0),COLORFF00FF,POINTDOT;
RSI底背:IF(B3>0,-0.1,0),COLORYELLOW,POINTDOT;
MACD顶背:IF(D1>0,0.1,0),COLOR00FF00,POINTDOT;
KDJ顶背:IF(D2>0,0.1,0),COLORFFCC66,POINTDOT;
RSI顶背:IF(D3>0,0.1,0),COLORWHITE,POINTDOT;
STICKLINE(B1>0,-0.1,0,2,0),COLORRED;
STICKLINE(B2>0,-0.1,0,2,0),COLORFF00FF;
STICKLINE(B3>0,-0.1,0,2,0),COLORYELLOW;
STICKLINE(D1>0,0.1,0,2,0),COLOR00FF00;
STICKLINE(D2>0,0.1,0,2,0),COLORFFCC66;
STICKLINE(D3>0,0.1,0,2,0),COLORWHITE;